Jump to content

Beautiful design, Morning owl look amazing.

This embroidery work up perfectly and stitch out nicely. 
Buy Now

Excellent stitches and original style

Stitched out beautifully! Looked amazing and no issues!
Buy Now

Loving birds.. Wonderful designs, stitched out beautifully

Really cute, You love this when you stitched it. Would love more of same designs.
Buy Now

Our designs looks great

Stitched out beautifully! Wonderful decoration!
Buy Now

Adorable design. Stitches out beautifully.

"Thanks so much for this design It's lovely and stitched out beautifully on leather."
Buy Now
KristinS

Brother PE770 stopped picking up the bobbin thread

Recommended Posts

So I have had my machine for a couple years now & I have always been able to figure out what is wrong & fix the issue any time I have had any problems with my machine. However, at the moment I have an issue I can’t resolve & was hoping you all might have some advice as to what to try next. I will be sure to try to provide as much information as I possibly can in regards to my issue, trouble shooting process & and any information in regurads to a solution should I find one for anyone else who might have the same issue

MY MACHINE – Brother PE770

MY ISSUE – In the middle of an order I was working on I started having issues with the top thread breaking & all of a sudden BLAM... a broken needle. Now after a bunch of troubleshooting, I can’t seem to get the machine to pick up the bottom (bobbin) thread anymore

WHAT I TRIED:

1 – Took a part the top & cleaned out any dust, removed any broken threads, ran a thick piece of heavy weight thread through the thread path to try to remove any excess dust, buildup or thread remnants.

2 – I changed the needle to a brand new one & then tried changing it to a brand new BP needle

3 – I opened up the bottom of the machine & removed bobbin case, cleaned out any dust in the bobbin space, removed any lint build up in the bobbin case itself, I cleaned the bobbin case thread path & re-set the tension a number of times

4 – I tried changing the bobbin thread to a new bobbin (90 weight as recommended for the machine) then tried using a bobbin with 60 weight bobbin thread just in case it might be that.

5 – I switched out my bobbin case for another one (I always keep a new replacement bobbin case in case of emergency) switched it back

AT THIS POINT I TURNED OFF THE MACHINE & WALKED AWAY SO I COULD CALM DOWN & NOT THROW MY MACHINE AT THE WALL…LOL.

6 – Upon return, I turned the machine back on & started my troubleshooting process again & went through the above process (1-5) this time oiling up the appropriate areas. Unfortunately there is still no change.

I can’t help but feel like there is something basic I’m missing here. I would be very thankful for any other suggestions that I might try to get this puppy up & running again. I have a stack of orders to work on & can’t really afford to send her to the shop to be fixed at the moment. 

 

Share this post


Link to post
Share on other sites

So is there ANYONE that has ANY advice at all?

did I not provide enough information?  Have I put this in the wrong category?  

Is there a reason I'm not getting any response at all?

Any advice would be greatly appreciated

 

Share this post


Link to post
Share on other sites

I would think that after all your efforts at sorting out the problem it could be the actual machine timing that is out of kilter.

Sincerely hope you get it sorted.

 

Share this post


Link to post
Share on other sites
10 minutes ago, Regiart said:

I would think that after all your efforts at sorting out the problem it could be the actual machine timing that is out of kilter.

Sincerely hope you get it sorted.

 

Thanks.. I'll check into that. Its a great sugestion as to a direction to take my troubleshooting. . I just downloaded a service manual so I will go straight to that section to see what my be required to test & reset that.  Thank you soooooooo much. 

Share this post


Link to post
Share on other sites

So as per the excellent suggestions I have gotten from the multiple forums I posted in I tried a few more things & actually found a solutions to my issue. I can’t thank everyone enough for all the wonderful advice of other things I should check. It was invaluable in my troubleshooting process. Solution or not it helped me rule out that possibility & I learn much more about machine
SUGGESTION 
Get a service manual - I found a downloadable service manual for the PE770. What a great suggestion… this manual is well worth the price as it provided me with a wealth of knowledge about my machine with diagrams making the troubleshooting process much easier.  

                                                                    SUGGESTION 

 

Check Needle bar height (should be between 1.6 - 2.0mm) – I was able to find the recommended needle bar height in the service manual under the “Adjustments” & used jeweler’s digital caliper to make a small test strip with the measurement. I then removed the bottom casing & plate to expose the hook (area the bobbing case sits in) & lowered the needle so I could position the measurement strip behind the needle & see if the space from the top of the eye in the needle & the bottom ridge of the hook matched the 2MM measurement. (Including some pictures for reference) My needle bar height was spot on, so not my issue. However the service manual I got does have instructions for the adjustment procedure if I needed it.

 


SUGGESTION  
Timing – After checking this, my timing seemed to be just fine.  This was an excellent video on how to check it

                                                                  SUGGESTION 

Remove the face plate & run a test pattern to check thread flow in action. This was a recommendation from a call I made to a repair shop that went out of business. Luckily the cell# was still active & I reached the ex-owners son who had worked on machines for years. After giving him the millage of my machine (which is very high..lol.. I use it A LOT!!!” he suggested it might be something a bit worn away in the upper thread path. He ran me through this process1-    thread the top thread with the face plate on & thread needle

2-    Remove the face plate. (do not move, touch or adjust your thread, just remove face plate)
3-    Set your hoop with test fabric & begin the test design
4-    Keep a close eye on the upper thread flow to check for snags, hang-ups or any other odd behavior.   
OMG…..VIOLA…. I immediately see the thread hung up on a small section of the thread guard piece (the one with the thread pattern step #4 on it. There is a section that with how much I used the machine had developed a worn away groove that the thread was running through that had developed a rough edge... 
5-    He then had me thread the top thread with the faceplate off to ensure the thread was not hung up & through the proper thread path & run of a test….  SUCCESS… machine is now embroidering beautifully
6-    At this point he had me file this down to smooth so that the thread no longer hangs up in this grove created from overuse.  
7-    Replace the faceplate & re-thread top thread
8-    Run a test pattern!
WOOOOHOOOO PROBLEM SOLVED & machine is preforming just as it should be and I think even better because I pretty much did a tune up to it going through all the troubleshooting. LOL

roflbot 1.jpg

roflbot 2.jpg

roflbot 3.jpg

roflbot 4.jpg

roflbot 5.jpg

roflbot 6.jpg

roflbot 7.jpg

roflbot 8.jpg

Share this post


Link to post
Share on other sites

I have experienced the same issue yesterday and this topic has 100% helped sorting out the problem which was irregular for over 4 months. But yesterday, the issue of piled thread under the fabric was so frastrating and reccuring untill I removed that part of thread guide ( labelled 4).

Now the machine pe770 is running withoutany abnormal sound and stitch is 100% perfect , no shreding of thread and no thread breaking any more

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...