Jump to content
  • Sign Up
  • Language

Thread not pushing through after auto trim :(


Recommended Posts

I'm running into an issue where the auto trim works then moves to the next object but the initial thread at the start of the new object doesn't push down and just hangs loose up top. Would anybody be able to help me fix this? I contacted brother support but they couldn't help. I have a brother NQ1600E embroidery machine. The top and bobbin tensions are set correctly where 1/3 bobbin shows on a stitchout of the letter I. I've tried going up and down with the tensions on both the top thread and the bobbin case to see if that would do anything but doesn't. I tried putting a spool net around the spool while it is being used and that makes it to where when the auto trim trims, it leaves a much smaller amount of thread length then the thread just slips out of the needle. If I go lower on the tension with the spool net on there's a tension where I can get it to where it cuts short and slips out about half of the time and then if I go any lower it's back to just having the hanging thread. using 75/11 needle with 40wt thread. video link attached, any help would be appreciated, thank you very much for your time!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...